How to Fix the Error “Your site is running an insecure version of PHP, which should be updated.”

PHP is a programming language that is used to build and maintain WordPress. WordPress currently is the largest content management system actively in use. Using an older version of PHP can leave your website vulnerable and exposed to malicious activities since older versions of PHP are considered insecure.

How to Update PHP?

On your WordPress Dashboard, you might have encountered the below error on Fig 1.0

1 FEXaPv1Tvi ol5FyUC9EYQ
Fig 1.0

Step 1

Login to your Cpanel Account of your website.

You can access your Cpanel by typing your website name followed by Cpanel e.g https://www.yourwebsitedomain/cpanel

Step 2

Once in the Cpanel, scroll down to Software category. See Fig 1.1 below

Fig 1.1

Step 3

Under software locate a feature called “multiPHP Manager”. See below Fig 1.2

Fig 1.2

Click on it and locate your website domain, select it by checking the box next to your domain. See below Fig 1.3

Fig 1.3

Step 4

Select your recommended PHP version from the drop-down arrow on the right side of your screen. Then click Apply. See Fig 1.4 Below

Fig 1.4

Step 4

Go back to your WordPress Dashboard and hit refresh.

Hurray!! The error has disappeared.

Congratulations your PHP version has been successfully updated.

Thank you!!

Leave a Comment

Your email address will not be published. Required fields are marked *